Garry's Mod
A sandbox game for the PC and Mac

Garry's Mod is a Sandbox Game based around the idea of building. Unlike most other games there aren't any objectives - you can't lose and you definitely can't win.

Update 165

👤 🕔 June 5, 2013 87
  • NEW Garry’s Mod is now on Steam Pipe
  • NEW Added the Portal 2 version of Chell as a player model
  • NEW Added back the CS:S hostage player models
  • NEW Added medic player models (and their arms)
  • NEW Phong & rimlight on players modulates based on their chosen color
  • NEW Adapted more zombie animations into the player model libraries
  • NEW Optimized CS:S player models
  • NEW Now colourable: CS:S Phoenix/Guerilla/Leet, Magnusson
  • NEW Improvements to the player model selection interface
  • FIXED Updated CS:S hands model and material
  • FIXED Fixed the remaining visual issues with CS:S c_models
  • FIXED Bullets properly come out of the barrel of CS:S weapons
  • FIXED Added missing medkit w_model
  • FIXED Thumbs on first-person medkit animations are less broken
  • LUA Added math.Remap( value, inMin, inMax, outMin, outMax )
  1. ShaunSki
    June 5, 2013 at 3:48 pm

    Awesome!

    Reply
  2. CanaaN
    June 5, 2013 at 4:11 pm

    Breaking everything on TCAdmin.
    Everything ever.
    Time to wait for my server hosting to update.

    Maybe.

    Reply
    • falon
      June 6, 2013 at 1:14 am

      it uses steamCMD now instead of hldsupdatetool…. if that’s any help.

  3. ShahoPC
    June 5, 2013 at 4:20 pm

    All servers need to update for this one.

    Reply
  4. Nuketown2000
    June 5, 2013 at 4:30 pm

    how do i update? or download the update?

    Reply
  5. deadpool033
    June 5, 2013 at 4:41 pm

    how do you use steampipe

    Reply
  6. Dylan Thomas
    June 5, 2013 at 4:55 pm

    how do i get my gmod to update? i dont know how and it wont automaticly update :(

    Reply
  7. miner6003
    June 5, 2013 at 5:08 pm

    How can i get the update? I’ve heard it’s supposed to be in my library but it’s not.

    Reply
  8. Spinti
    June 5, 2013 at 5:20 pm

    It wont auto update

    Reply
  9. stavik
    June 5, 2013 at 5:20 pm

    how do i start the update? :/

    Reply
  10. Durka
    June 5, 2013 at 5:39 pm

    HOW DO WE UPDATE!?

    Reply
  11. DouthyDuck
    June 5, 2013 at 5:45 pm

    i have updated the game and then it still says that it cannot connect to a server due to a new version of the game? whats happening?

    Reply
    • kevin
      July 15, 2014 at 3:00 pm

      how did you get the update

  12. TheSarge13
    June 5, 2013 at 6:16 pm

    Jesus. All the servers can’t update! Mutilplayer atm is screwed.

    Reply
  13. Cakemix
    June 5, 2013 at 6:27 pm

    To update you must verify game cache then afterwards it will download the 1000+ files required. not sure if its just me though but its going extremely slowly so be careful.

    Reply
    • DouthyDuck
      June 5, 2013 at 6:33 pm

      how exactly do you do that?

  14. Ryan H
    June 5, 2013 at 8:01 pm

    Right click Gmod in your library, click on “properties” at the bottom of the list. Go to “locaal files” and click “view integrity of game” and you should have the new update.

    Reply
  15. Wulfstorm
    June 5, 2013 at 8:16 pm

    Downloading the update now, hope servers get updated soon ^_^
    Fast DL’s :D :D :D

    Reply
  16. Lucky-Dice
    June 5, 2013 at 8:22 pm

    Jesus Christ the download is sloooow

    Reply
    • Wulfstorm
      June 5, 2013 at 8:30 pm

      It’s worth it though look at the benefits:

      -Faster downloads
      -Faster map load times and much faster boot times
      -Easier distribution, installation, and management of mods

      I’m so excited :P

    • Francis
      June 5, 2013 at 8:56 pm

      i hope, theres only one way to find out. this 2GB update better be bloody worth it and all my darn servers better be preserved

  17. caleb200790
    June 5, 2013 at 8:45 pm

    Guys, it updates the same as usual, it auto-updates, that is, if you legally bought the game!

    Reply
    • TheAndroid1
      June 5, 2013 at 9:09 pm

      We are talking about SERVERS, not CLIENTS.

  18. William
    June 5, 2013 at 9:05 pm

    Maps are completely broken.

    Reply
    • Garry Newman
      June 5, 2013 at 10:00 pm

      Which maps?

    • Wacky
      June 7, 2013 at 4:34 pm

      Hey, Garry my server keeps on messing up everytime i join it, it will say this MasterRequestRestart
      Your server needs to be restarted in order to receive the latest update.
      Your server needs to be restarted in order to receive the latest update. Please help me?

    • Arthur G
      June 7, 2013 at 7:00 pm

      TTT maps like 67thway_v3 and others have now missing textures for no reason, worked perfectly before updated, is there a way to fix that?

    • Sam Lee-Croll
      June 8, 2013 at 1:03 pm

      Advanced Duplicator 2 is broken by Update 165, have tried updating server, no fix. On single player we get:

      addons/advdupe2/lua/advdupe2/sv_codec.lua:358: attempt to index upvalue ‘buff’ (a nil value)
      [

      and on Multi we get an EOF error: addons/advdupe2/lua/advdupe2/sh_codec.lua:237: expected value, got EOF[AdvDupe2Notify] Could not open addons/advdupe2/lua/advdupe2/sh_codec.lua:237: expected value, got EOF

  19. Tyler
    June 5, 2013 at 9:55 pm

    It seems that I can’t mount Counter-Strike:Source anymore despite it working just fine yesterday. It’s installed and everything.

    Reply
  20. Bishie
    June 5, 2013 at 10:06 pm

    I’m experiencing the same difficulties as Tyler, except it’s Half-Life 2: Episode Two that I cannot mount. It can’t be selected, and so I lack the appropriate textures in certain maps. The suggestion you posted, Garry, hasn’t solved the problem.

    Reply
    • Garry Newman
      June 5, 2013 at 10:09 pm

      You need to join the Steam Pipe beta for Episode 2

    • Bishie
      June 5, 2013 at 10:14 pm

      Forgive my ignorance. That appears to have solved the problem, thanks.

  21. Vladimir
    June 5, 2013 at 10:21 pm

    Garry please fix the servers! I can’t play anything! :c

    Reply
    • matt ouimet
      June 6, 2013 at 2:57 am

      the update is not letting my play too

  22. McSchmidty
    June 5, 2013 at 10:49 pm

    I’m on an iMac computer and I get an engine error that states the following: Steam Error: No SteamUser.

    – Make sure that Steam is up to date.
    – Try restarting your PC.
    – Try Garry’s Mod -> Delete Local Content

    Please let me know if you solve this bug!

    I’ve tried reinstalling gmod, updating steam, restarting my computer, can’t get it working.

    Reply
    • Deadlyfluffball
      June 6, 2013 at 12:24 am

      Same thing with me! I’ve done everything and nothing helped!

    • McSchmidty
      June 6, 2013 at 12:50 am

      This is really stressing me out, I’ve been looking forward to playing all day :s

    • Deadlyfluffball
      June 6, 2013 at 2:58 am

      Yer, I was hoping this would fix the Ep.2 maps being messed up.

  23. fraq
    June 6, 2013 at 12:20 am

    hey garry would be so bad to include all it’s needed from css in gmod?

    Reply
  24. Nobody
    June 6, 2013 at 12:39 am

    PLEASE make a css compatability pack that comes standard with gmod, the majority of TTT players have forgot to update css with gmod and as many things are dependant on owning BOTH games this would be very useful.

    Reply
  25. falon
    June 6, 2013 at 1:12 am

    Forgot to add that you limited downloadable content….

    Reply
    • falon
      June 6, 2013 at 1:12 am

      to roughly 8000 files…. why limit the users?

  26. Buggarach
    June 6, 2013 at 3:11 am

    Uh Garry?! What the fuck happened to Gmod. It was working fine 5 hours ago and now I get this message saying that I need to check if its updated, and that I should delete my local files. “Let me know if you fix this bug” is what it says at the end.

    Anyone else see this?!!

    Reply
  27. 00875
    June 6, 2013 at 3:12 am

    After new feature “Improvements to the player model selection interface”, the not standart (not humans) playermodels not working! Please fix it.

    Reply
  28. Joshua
    June 6, 2013 at 6:30 am

    Sorry for the Intrusion on this comment, My Garry’s Mod (TTT) server wont mount CS:S properly. I have tried almost everything possible and there is still fast reload and people are walking through certain box props. Any ideas anyone?

    Reply
    • Arthur G
      July 3, 2013 at 2:50 am

      I`ve got that “going trough props” problem too, garry, please tell us what to do?

  29. Thunder
    June 6, 2013 at 11:15 am

    Hi all. I just got gmod last night and noticed two issues straight away, first when I had the game open the quit/disconnect option was greyed out and the only way to close the game was through task manager. It then gives me the message hl2.exe has stopped responding. The other was the server list was bugged out, I could only see the end of the servers rating not the map or player count. Anyone know how to fix these two issues? I’ve tried reinstalling. Anyone else?

    Reply
  30. Chenk
    June 6, 2013 at 12:01 pm

    i have this anoying problem where gmod is using the cs:go sounds on the css weapon ans because of that i can only hear and anoying beep on some weapons like galil and mp5 anyone know how to fix?

    Reply
    • Chenk
      June 6, 2013 at 1:21 pm

      ok fixed my problem all i had to do was reinstall gmod and make sure that cs:go is DISABLED or else it would just happen again

  31. itstystaTysta
    June 6, 2013 at 5:44 pm

    Alright, there seems to be a terrible sound glitch with TTT weapons. All I hear when firing them is a squeek (as mentioned by Chenk above me).

    I have CS:S and CS:GO installed, updated, and mounted. Trying to revify my Gmod filed now, but nothing has worked so far.

    Reply
    • Tysta
      June 6, 2013 at 5:50 pm

      Verifycation didn’t fix anything, nor did remounting and rebooting a few times. Anyone have a clue how to fix the sounds?

    • Pingas
      June 6, 2013 at 7:20 pm

      Its the update, it broke the sounds. Wait until Garry finds it.

  32. Joshua
    June 6, 2013 at 7:27 pm

    This update destroyed my server.
    Alot of hard work for nothing…

    Reply
    • raceprokid
      June 7, 2013 at 4:27 am

      Pretty much. I’ve been working, downloading, researching and waiting for two days to update my DarkRP server to “SteamCMD” and have gotten nowhere. It’s confusing, slow, and a huge downgrade. My server was just getting to be popular and one of the top DarkRP servers. Can’t Garry or someone just make an update for SRCDS? :/

  33. Marley
    June 6, 2013 at 9:17 pm

    why 2 gig update?!??

    Reply
  34. falon
    June 6, 2013 at 11:24 pm

    Please remove the limited content table…. that is really annoying… because even with a FASTDL it doesn’t work.

    Reply
    • falon
      June 6, 2013 at 11:25 pm

      Warning: Table downloadables is full, can’t add …..

  35. Markusmoo
    June 7, 2013 at 1:42 am

    Hey guys so I just installed the update and none of my addons are being detected by Garrys Mod and as well as my maps are all gone. I checked the folder and they are all still in their respected folders. Any help?

    Reply
  36. GfvgBawssGmod
    June 7, 2013 at 1:54 am

    This update sucks.
    I can’t go on my saves, I lost my dupes, the HL2 maps aren’t there anymore, and there’s probably more problems I still haven’t see….

    Reply
  37. fucksake
    June 7, 2013 at 7:28 pm

    Okay so i now have to re-download everything!

    Reply
  38. ShadowOfDoubt
    June 7, 2013 at 11:40 pm

    Eversince this “update”. My GMod no longer functions, it starts up onto the loading screen,. Then just freezes.

    Reply
    • ShadowOfDoubt
      June 7, 2013 at 11:41 pm

      I have also validated, and the cache via properties. But my game also didn’t auto update for Steam pipe.

  39. HazaShotz
    June 8, 2013 at 2:33 am

    Whenever i try to go into a TTT server it says “You cannot join this server because you need to update your client” and i just got done updating it and i tried restarting my computer, restarting steam, and that’s about it. I don’t know what i should do

    Reply
  40. Fibritz
    June 8, 2013 at 8:06 am

    I can’t mount anything CS:S (episodes, lost coast etc) I think that I’ve updated everything to steampipe already (by checking “view integrity of game”) but still, I can’t get the mounts help!

    Reply
  41. Flamez
    June 8, 2013 at 12:21 pm

    Worst Gmod update ever. DOES HE NOT TEST THESE UPDATES?

    Reply
  42. Tripps
    June 8, 2013 at 12:47 pm

    In the mist of this you fucked up one of the most played gametypes “DarkRP”.
    You need to do testing before forcing update.

    Reply
  43. RaptorBeast7
    June 10, 2013 at 10:58 pm

    for some reason, after update 165, i switched my hl2, ep1, and ep2 to SteamPipe, and now it wont mount into gmod.

    Reply
  44. Monster
    June 14, 2013 at 5:46 pm

    Please, remove the limit of download of file, that breaks many of gamemode…

    Reply
  45. Fries
    June 23, 2013 at 1:04 am

    Pink and black texture board textures everywhere. I am disappoint.

    Reply
  46. SomeoneWhoIsSickOfSteamPipe
    June 23, 2013 at 10:18 pm

    THIS IS FUCKING SHIT! GET IT THE FUCK OFF STEAM PIPE!

    Reply
  47. michael
    June 24, 2013 at 2:57 am

    My server wont mount counter strike or tf2, and i typed in the locations on mount.cfg.

    Reply
  48. jacob
    June 25, 2013 at 8:20 am

    garry why do you ignore your fans

    Reply
  49. Burger
    July 5, 2013 at 4:21 pm

    Cant update my steamcmd server! Need help

    Reply
  50. Kelly
    July 7, 2013 at 5:12 pm

    Hi,

    I am trying to help my son with two issues. First, it appears that the Steampipe conversion did not take for Garrys Mod. He is having the issue of not being able to log into servers due to version, and the Garrys Mod file still appears in the /username folder, not the /common folder. I’ve verified caches, and looked around for guidance on the steam community forums, but haven’t found an article which addresses how to re-initiate the Steampipe conversion if it did not complete. Any suggestions would be helpful. We are on a Mac, running OSX 10.7.5. All other games are appearing fine in the /common folder, so it appears to just be Garrys Mod.

    The second issue is related to a sound file. He is saying that his Desert Eagle firing and reloading sounds are not correct. He has several addons installed that are related to the desert eagle, and I am not sure if one of them could possibly cause an interference with the basic sound file, perhaps? In the /steamapps/username/garrysmod/garrysmod/sound/weapons/deagle folder, he has two files, which are colt_fire_v2.wav and gdeagle-reload.wav

    Any suggestions would be greatly appreciated!

    Reply
  51. FireTeaM.Fr
    July 24, 2013 at 12:37 pm

    Hello, since the update, my server has a bug, all props, entities, doors become invisible, players are forced to reconnect to the server and I noticed that this happens randomly but very often and even disabling DarkRP and the addons, I still have this problem. I try solo and it makes me like when I see a number of props, thank you for your understanding. awaiting a response

    Reply
  52. Waldo (my steam username)
    July 26, 2013 at 2:30 pm

    Since I got Steampipe, my game crashes on startup and I have tried to reinstall Gmod over and over, and I have tried unsubscribing from addons and it seems nothing works. If the game does start its extremely slow, and I usually have to stop the program via task manager. I need help! D:

    Reply
  53. brewster Thomas koopa I
    August 3, 2013 at 5:27 pm

    Garry can you fix your game most of the community are alot slower on loading and some have good computers it takes half an hour to load a map and 5 minutes to load up

    Reply
  54. TRON NO LOL 753
    August 7, 2013 at 12:59 am

    its updating fast for me

    Reply
  55. TRON NO LOL 753
    August 7, 2013 at 1:02 am

    when i didint know about the update my gmod kept logging out why garry and i cant get on gmod tower it sais missing maps thanks for answering
    any one else know

    Reply

Leave a Reply